DaveInFL
Posts: 4
Joined: Tue May 24, 2022 8:44 pm

MAME running at under 50% when external monitor connected

Hi,

Took me a while to figure out what was going on, but it appears when I run MAME and I have an external monitor connected (In fact I have 2 external monitors. I usually have my laptop closed and used the dual monitor setup. However, even with 1 external monitor connected I get the same issue) then MAME runs at under 50% and the games are just slow and choppy. No idea why this would happen. I've changed the resolution on the external monitor to be low, but same issue. It's been a while since I had MAME up and running and don't recall having this issue in the past.

I'm running the latest version, 0.243, on an M1 Mac. The Mac has 32GB memory and 24 cores, so it's got plenty of power.

The two monitors are Dell P2415Q monitors that have a maximum resolution of 3840x2160. But they are both running at 2560 x 1440 @ 30Hz.

Maybe this is a known issue and maybe there's a solution for this too. I hate to be restricted to only use MAME on my laptop screen and not my actual monitor.

The other thing I can state is that one monitor is connected via USB-C into a USB-C Hub. The other monitor is connect via HDMI directly to the laptop.

I am totally at a loss as to how to even go about troubleshooting this, or resolving the issue, so any help would be much appreciated. I'm sure I can't be the only person using external monitors and running MAME without issue.

DaveInFL
Posts: 4
Joined: Tue May 24, 2022 8:44 pm

Re: MAME running at under 50% when external monitor connected

I am thinking this has something to do with MAME for the M1 Mac. I downloaded MAME for windows and installed that under Windows 11, which is running in a virtual machine on my Mac. Runs just fine on windows, even in a VM on the same external monitor.

So, no idea why running the native MAME on the Mac would cause a 50% slow down!

Hoping someone has some idea why. I'd rather run MAME natively on my Mac than have to boot up a VM running windows every time I want to run MAME.

User avatar
Tafoid
Posts: 315
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: MAME running at under 50% when external monitor connected

DaveInFL wrote:
Fri May 27, 2022 1:47 pm
I am thinking this has something to do with MAME for the M1 Mac. I downloaded MAME for windows and installed that under Windows 11, which is running in a virtual machine on my Mac. Runs just fine on windows, even in a VM on the same external monitor.

So, no idea why running the native MAME on the Mac would cause a 50% slow down!

Hoping someone has some idea why. I'd rather run MAME natively on my Mac than have to boot up a VM running windows every time I want to run MAME.

You don't mention a specific machine example - are all games performing equally as bad?
If so, you may be up against a video configuration issue where the driver/hardware itself may be determining your speed based on your particular driver/configuration choice. You can attempt using other video modes and see if that improves things (opengl, bgfx).

DaveInFL
Posts: 4
Joined: Tue May 24, 2022 8:44 pm

Re: MAME running at under 50% when external monitor connected

Tafoid wrote:
Mon May 30, 2022 11:40 pm
DaveInFL wrote:
Fri May 27, 2022 1:47 pm
I am thinking this has something to do with MAME for the M1 Mac. I downloaded MAME for windows and installed that under Windows 11, which is running in a virtual machine on my Mac. Runs just fine on windows, even in a VM on the same external monitor.

So, no idea why running the native MAME on the Mac would cause a 50% slow down!

Hoping someone has some idea why. I'd rather run MAME natively on my Mac than have to boot up a VM running windows every time I want to run MAME.

You don't mention a specific machine example - are all games performing equally as bad?
If so, you may be up against a video configuration issue where the driver/hardware itself may be determining your speed based on your particular driver/configuration choice. You can attempt using other video modes and see if that improves things (opengl, bgfx).
Yes, this is for all games, or at least all games I have tried and I've tried 30+. I'm not that familiar with MAME, could you point me in the right direction as to how to use other video modes and what the video mode options are for M1 Mac?

User avatar
Tafoid
Posts: 315
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: MAME running at under 50% when external monitor connected

DaveInFL wrote:
Tue May 31, 2022 5:21 pm
Tafoid wrote:
Mon May 30, 2022 11:40 pm
DaveInFL wrote:
Fri May 27, 2022 1:47 pm
I am thinking this has something to do with MAME for the M1 Mac. I downloaded MAME for windows and installed that under Windows 11, which is running in a virtual machine on my Mac. Runs just fine on windows, even in a VM on the same external monitor.

So, no idea why running the native MAME on the Mac would cause a 50% slow down!

Hoping someone has some idea why. I'd rather run MAME natively on my Mac than have to boot up a VM running windows every time I want to run MAME.

You don't mention a specific machine example - are all games performing equally as bad?
If so, you may be up against a video configuration issue where the driver/hardware itself may be determining your speed based on your particular driver/configuration choice. You can attempt using other video modes and see if that improves things (opengl, bgfx).
Yes, this is for all games, or at least all games I have tried and I've tried 30+. I'm not that familiar with MAME, could you point me in the right direction as to how to use other video modes and what the video mode options are for M1 Mac?

- Start MAME emulator
- Choose "Configure Options"
- Choose "Video Options"
- Choose "Video Mode"

Depending on your OS, you should have a selection of different video modes available. Try anything available to you - save settings - then try again.

Alternatively, Your OS's graphic drivers or setting may be using some video syncing whereas if a game is expecting 60Hz display and you feed it to a 120Hz, you may very well indeed have slow down universally.

DaveInFL
Posts: 4
Joined: Tue May 24, 2022 8:44 pm

Re: MAME running at under 50% when external monitor connected

Thanks, that worked. Changed to OpenGL and all running good now.

Return to “MAME Discussion”