OverLander
Posts: 8
Joined: Sun Dec 04, 2016 11:18 pm

MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Mon Dec 05, 2016 7:24 pm

Hello ,

I am refreshing my Arcade cabinet with new Hardware an Software.

I am running WInPro 10 64bit with MAME 0.180 64-bit

Mame ran fine for a few hours, had it running and was setting up mGalaxy when the Mame64 .exe
suddenly decided to stop loading ..........

I get ... Black screen with spinning blue disc then ... Window with the following text...

MultipleArcade Machine Emulator has stopped working

A problem has caused the program to stop workingcorrectly.
Windows will close the program and notify you if a solution is
available.

CLose Program

No further information is available and the program does not appear in Task Manager.

Have re installed everything from scratch ... virus scan done ...

Any Help would be great ..

Thanks

Jon


System specs

MSI H81m Pro VD
4G DDR3
Intel Pentium K G3258 3.2Ghz Dual Core
Onboard Iris graphics
PNY SSD 120G

Win Pro 10 64 Bit

OverLander
Posts: 8
Joined: Sun Dec 04, 2016 11:18 pm

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Wed Dec 07, 2016 5:12 pm

Seems that a fresh install of win10 on a formatted disk will allow Mame to load but after a reboot
it wont run.

Here is the event log from Event Viewer if anyone can advise ?

Thanks

Jon

Faulting application name: mame64.exe, version: 0.180.0.0, time stamp: 0x058402e0
Faulting module name: mame64.exe, version: 0.180.0.0, time stamp: 0x058402e0
Exception code: 0xc0000005
Fault offset: 0x000000000165d779
Faulting process ID: 0xe5c
Faulting application start time: 0x01d250a1b062e202
Faulting application path: C:\Users\Arcade\Desktop\Mame\mame64.exe
Faulting module path: C:\Users\Arcade\Desktop\Mame\mame64.exe
Report ID: 6ba6ec8b-cfb5-4c33-8ecc-c4231efb0412
Faulting package full name:
Faulting package-relative application ID:

User avatar
B2K24
Posts: 44
Joined: Wed Mar 30, 2016 5:43 am

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Thu Dec 08, 2016 1:07 am

This is rather strange. I run Windows 10 Pro X64 as well and I've never had any issue running MAME. Perhaps make sure you have all the DirectX stuff installed and try running MAME from a USB flash drive rather than C:\ to see if that makes any difference.

OverLander
Posts: 8
Joined: Sun Dec 04, 2016 11:18 pm

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Thu Dec 08, 2016 4:45 pm

Thanks for the advice ...

No change running from USB drive

I have a feeling that its something that Win10 is loading on first reboot after installation ...

Can anyone tell me what the Faulting process ID: 0xe5c actually is ?

J

OverLander
Posts: 8
Joined: Sun Dec 04, 2016 11:18 pm

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Thu Dec 08, 2016 11:29 pm

I can now run Mame64 from CMD prompt as Admin ...

But it wont run from WIn10 GUI

When I do run Mame64 this way, it cant see the Roms in Rom folder ( I have to point it to the Rom directory )

Below is the output text from CMD Promt..... ( Without starting a rom )
Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\Windows\system32>C:\Users\Arcade\Desktop\Mame\mame64
m_xAudio2->CreateMasteringVoice( &temp_master_voice, format.nChannels, sample_rate()) failed with error 0x80070490
create_voices(format) failed with error 0x80070490

C:\Windows\system32>

User avatar
B2K24
Posts: 44
Joined: Wed Mar 30, 2016 5:43 am

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Fri Dec 09, 2016 1:35 am

For simplicity you might consider moving your mame folder to the root of your C:\ drive

C:\MAME

It looks like there's some issue with xAudio2 so try changing the sound to dsound. You can do this by accessing mame.ini and changing sound option to dsound

mame64 -sound dsound setname

OverLander
Posts: 8
Joined: Sun Dec 04, 2016 11:18 pm

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Fri Dec 09, 2016 7:59 pm

Ok cool Ill try that .... but I have searched for mame.ini and I cant find it anywhere ?

User avatar
Tafoid
Posts: 144
Joined: Thu Nov 06, 2014 12:50 pm
Location: Vermont USA
Contact: Website

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Fri Dec 09, 2016 8:41 pm

OverLander wrote:Ok cool Ill try that .... but I have searched for mame.ini and I cant find it anywhere ?
It would likely say in your mame.ini

Code: Select all

sound auto
Default (auto) for Windows 10 and some Windows 8 systems is the xaudio2 protocol. dsound is used elsewhere and may help your situation.

OverLander
Posts: 8
Joined: Sun Dec 04, 2016 11:18 pm

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Fri Dec 09, 2016 9:33 pm

There is no mame.ini file on this PC anywhere ...

Any ideas ?

J


Just ran CMD line ... mame64 -cc

created mame.ini file

OverLander
Posts: 8
Joined: Sun Dec 04, 2016 11:18 pm

Re: MAME 0.180 64-bit - Win Pro 10 64 - Mame wont load

Fri Dec 09, 2016 10:24 pm

Making progress now .... after editing mame.ini....

Changing to dsound made no difference

If I force windowed mode from mame.ini then mame runs but shows audio errors when loading...

My problem seems to be arising when going from the win10 desktop to mame ui fullscreen mode ...

Thanks for help so far ...

J

Return to “MAME Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests