Page 1 of 1

MAME display issue

Posted: Tue Jul 10, 2018 4:09 am
by ginjirou
MAME display issue 1.JPG
MAME display issue 1.JPG (103.41 KiB) Viewed 525 times
MAME display issue 2.JPG
MAME display issue 2.JPG (90.28 KiB) Viewed 525 times
MAME display issue 3.JPG
MAME display issue 3.JPG (72.41 KiB) Viewed 525 times
Above are screenshots of a display issue I am having with MAME. The games are stretched horizontally and don't fit in the window. I run MAME using Emu Loader frontend. Does anyone know how to fix this?

Re: MAME display issue

Posted: Tue Jul 10, 2018 7:04 pm
by kirishima
1. Have you checked to see if the issue persists without the front end? Are you using the official builds: http://mamedev.org/release.html

2. Does the issue show up in fullscreen mode? Have you adjusted the horizontal stretch in the sliders menu?

Re: MAME display issue

Posted: Wed Jul 11, 2018 4:06 am
by ginjirou
I am using the official build from the site which I updated two weeks ago. A front end is the only way I know how to run MAME. I will try playing with the horizontal stretch sliders and get back to you whether that resolves the issue. This issue shows up both in windowed and full screen modes, but is more pronounced in windowed mode. This does not happen with the other unofficial MAME builds that I have such as MAMEUI64

Re: MAME display issue

Posted: Wed Jul 11, 2018 8:15 am
by Tafoid
ginjirou wrote:
Wed Jul 11, 2018 4:06 am
I am using the official build from the site which I updated two weeks ago. A front end is the only way I know how to run MAME. I will try playing with the horizontal stretch sliders and get back to you whether that resolves the issue. This issue shows up both in windowed and full screen modes, but is more pronounced in windowed mode. This does not happen with the other unofficial MAME builds that I have such as MAMEUI64

There is nothing default to MAME's setup that would cause your output to show like you have presented.
MAME has an internal front-end which is capable enough to run any title it can find a romset for. I would suggest installing the latest (0.199) in a new folder and then either drag a romset you want to test to "ROMS" in that new folder or launch MAME64 and set your rompath in the user interface: Configure options -> Configure Directories -> ROMs .. adding whatever folders needed.

My guess is that, by default, things should work fine for you. Since you give no driver/video card information we are left to guess just what is happening on your system other than you seem to be using Windwos 10 unactivated.

Re: MAME display issue

Posted: Sat Jul 14, 2018 6:39 pm
by ginjirou
Here are screenshots of my system specs and front end video options. So far I have been playing around with the settings with no luck in correcting the issue.
Emu Loader video 1 settings.JPG
Emu Loader video 1 settings.JPG (117.41 KiB) Viewed 430 times
Emu Loader video 2 settings.JPG
Emu Loader video 2 settings.JPG (69.11 KiB) Viewed 430 times
System Specs.JPG
System Specs.JPG (55.38 KiB) Viewed 430 times

Re: MAME display issue

Posted: Thu Jul 26, 2018 5:49 am
by B2K24
You're not keeping the original aspect ratio so it's being stretched on your display. I'd recommend changing rendering options.

I've never used Emu Loader but there needs to be an option that restores all options to default as if you just created a fresh mame.ini

Re: MAME display issue

Posted: Thu Jul 26, 2018 8:01 am
by f205v
This should fix your problem.

Image