User avatar
jnr
Posts: 3
Joined: Mon Jul 24, 2017 2:49 am

HLSL requiring older DirectX 9?

Latest MAME 0.222 on a brand new Windows 10 setup gives the following verbose output:

Direct3D: Initialize HLSL
Direct3D: Unable to find D3DXCreateEffectFromFileW

Does it requires specifically DirectX 9?

Wouldn't be better if supporting Windows 10 DirectX 12?

User avatar
Tafoid
Posts: 205
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: HLSL requiring older DirectX 9?

jnr wrote:
Tue Aug 04, 2020 6:18 am
Latest MAME 0.222 on a brand new Windows 10 setup gives the following verbose output:

Direct3D: Initialize HLSL
Direct3D: Unable to find D3DXCreateEffectFromFileW

Does it requires specifically DirectX 9?

Wouldn't be better if supporting Windows 10 DirectX 12?

Ideally, yes. It is always better to have support for the most currently available techniques. AFAIK, there are technical hurdles to changing rendering to newer Direct X versions as well as HLSL support for those versions which have not been worked out. I'd suggest using BGFX or OPENGL as a video mode. Render speeds are comparable to those of d3d9 and does not require special Windows support.

If you really want to use the d3d9, There is no way around it and you'll need to installed the End-User runtime:
https://www.microsoft.com/en-us/downloa ... px?id=8109

User avatar
jnr
Posts: 3
Joined: Mon Jul 24, 2017 2:49 am

Re: HLSL requiring older DirectX 9?

Got it. Let's hope that with time most recent DirectX gets supported, as the best experience depends on HLSL, which is amazingly nice :)

Thank you!

Return to “MAME Discussion”