Bongo
Posts: 3
Joined: Sat Oct 24, 2020 2:25 pm

Invaders Revenge sound

Hi

Does anyone know which version of Mame plays Invaders Revenge with the sound ok ? I'm sure I had it working ok years ago ??

Thanks for your help . . .

User avatar
Tafoid
Posts: 295
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: Invaders Revenge sound

Bongo wrote:
Mon Oct 26, 2020 2:25 pm
Hi

Does anyone know which version of Mame plays Invaders Revenge with the sound ok ? I'm sure I had it working ok years ago ??

Thanks for your help . . .

Current sounds are correct but the pitch might be off. Back long ago MAME had mistakenly given them the "invaders" sample pack .wav files and in development of MAME 0.210, correct emulation was added which uses the AY-8910 instead. This is precisely how it is supposed to sound.

Bongo
Posts: 3
Joined: Sat Oct 24, 2020 2:25 pm

Re: Invaders Revenge sound

Hi

Thanks for the prompt reply. My query is how to get any sound with that game because none of the versions I have tried it on plays it with sound ?

Am I missing something. The rom says it lacks sound when it loads up ??

Regards

User avatar
Tafoid
Posts: 295
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: Invaders Revenge sound

Bongo wrote:
Mon Oct 26, 2020 3:57 pm
Hi

Thanks for the prompt reply. My query is how to get any sound with that game because none of the versions I have tried it on plays it with sound ?

Am I missing something. The rom says it lacks sound when it loads up ??

Regards

Are we talking about the same game?
http://adb.arcadeitalia.net/dettaglio_m ... e=invrvnge

Originally, Invader's Revenge (shortname: invrvnge) either didn't have sound or incorrectly emulated sound via "invaders.zip" sound samples used for many "Space Invader" type games at one time. All MAME releases since 0.210 has the properly emulated sound as I mentioned above. Anything either depending on a sample pack or incorrect/lack of any emulation. I'd assume the MAME version you are using is older than MAME 0.210 and will likely not make any sounds being flagged as such in game information.

Bongo
Posts: 3
Joined: Sat Oct 24, 2020 2:25 pm

Re: Invaders Revenge sound

Hi

Yes that's the one, so are you saying there's no way of playing it with ANY sound anymore. Incorrect sound is still better than none.

Sorry if I'm missing the point :D

User avatar
Tafoid
Posts: 295
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: Invaders Revenge sound

Bongo wrote:
Wed Oct 28, 2020 7:57 pm
Hi

Yes that's the one, so are you saying there's no way of playing it with ANY sound anymore. Incorrect sound is still better than none.

Sorry if I'm missing the point :D

Update MAME to current (0.226). You'll have sound. That is what I am saying.

Simply trying to explain to you that older versions (anything before MAME 0.210) which you are using cannot magically HAVE sound, it is part of the emulator and as such will only show up if you update the emulator itself.

User avatar
Robert
Posts: 119
Joined: Thu Nov 06, 2014 12:44 pm
Location: Land of Oz
Contact: Website

Re: Invaders Revenge sound

Sound will be more accurate on 0.227, when it gets released at the end of November.

Return to “MAME Discussion”