alexem82
Posts: 2
Joined: Sun Oct 18, 2020 2:02 pm

MAME on Linux Mint XFCE 20.1 (Ulyssa)

Hello guys.
Long time fan of the project, first time writer on the forum.

I'm having fun with an old machine from 2006 (I know!) where I've installed Linux Mint XFCE, latest edition 20.1 (Ulyssa).
I have MAME 0.220 installed and properly configured.
On another old machine (WIN 7) I have MAME 0.161.
My Windows MAME is loading a game (Neo Turf Masters) that my Linux MAME cannot load (saying it's missing the particular BIOS).

How is it possible that the 2015 windows version can play it?
Is the Windows MAME including loads of BIOS as well?

Grateful for all the answers.
Thanks in advance.

Stay safe,

Alex

User avatar
Tafoid
Posts: 295
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: MAME on Linux Mint XFCE 20.1 (Ulyssa)

alexem82 wrote:
Wed Jan 13, 2021 5:39 am
Hello guys.
Long time fan of the project, first time writer on the forum.

I'm having fun with an old machine from 2006 (I know!) where I've installed Linux Mint XFCE, latest edition 20.1 (Ulyssa).
I have MAME 0.220 installed and properly configured.
On another old machine (WIN 7) I have MAME 0.161.
My Windows MAME is loading a game (Neo Turf Masters) that my Linux MAME cannot load (saying it's missing the particular BIOS).

How is it possible that the 2015 windows version can play it?
Is the Windows MAME including loads of BIOS as well?

Grateful for all the answers.
Thanks in advance.

Stay safe,

Alex

Requirements change from release to release. While many romsets are already "set" and will never need to be updated, Neo-Geo is notorious of being one of those drivers which has romset (neogeo.zip) changes every year or so to account for new releases of the very popular Universal BIOS updates. MAME will tell you, in very plain means, what is missing and what is expected. Your romset or bios is required to have all the pieces and will not allow emulation if missing even if those older romsets worked prior.

So, you'll need to find the latest "neogeo.zip" somewhere on the web, to allow any neo geo games to work in later versions. We cannot help you locate this.

Read up on romsets and requirements here: https://docs.mamedev.org/usingmame/aboutromsets.html

alexem82
Posts: 2
Joined: Sun Oct 18, 2020 2:02 pm

Re: MAME on Linux Mint XFCE 20.1 (Ulyssa)

Thank you very much.
I forgot all this.
Tbh, I solved the problem myself but unearthed about 20 more.

Nothing that a skillful use of Google can't solve.

I've got million other questions but I'll keep them for when I REALLY need help.

Thanks again.

Alex

Return to “MAME Discussion”