mrfe
Posts: 2
Joined: Thu Jul 15, 2021 9:19 am

Jingle Bell (USA)

Hello,
I would like a little help with rom (Jingle Bell)
In MAME, the rom info is Driver is parent, Overall: working, Graphics and Sound OK
But when I try to run it, I get the following error: Required rom/disk images for the selected system are missing or incorrect. Please acquire the correct files or select a different system. ym2413_instruments.bin not (ym2413) - not found. Pres any key to continue.

Do you know where I can get that missing .bin? and where is it missing from?

MAME version is 0.233 2021-07-01

Thanks
Last edited by Stiletto on Sat Jul 17, 2021 12:12 am, edited 1 time in total.
Reason: Deleted ROM website link.

User avatar
Stiletto
Posts: 84
Joined: Thu Nov 06, 2014 4:11 pm

Re: Jingle Bell (USA)

Hello.

First of all, please don't link to ROM websites here. See the forum rules: https://forum.mamedev.org/viewtopic.php?f=14&t=71

Second of all, you really are missing something. It's the internal sound data ROM for the Yamaha YM2413 chip used by the game. This previously was not required but the new Yamaha emulation externalized some of the data that used to be contained embedded in MAME's sourcecode (due to copyright concerns). Sometimes for this and many other reasons, ROM sets change: https://docs.mamedev.org/usingmame/aboutromsets.html

In this case, it's known as a "device ROM" as the YM2413 chip was used in many different games - rather than add a single file to every game ROM set that needs it (which you still can do anyways if you really want), we allow this file to be separate in a file called "ym2413.zip". So that is what you need to acquire. Unfortunately we cannot help you to do that.
- Stiletto

mrfe
Posts: 2
Joined: Thu Jul 15, 2021 9:19 am

Re: Jingle Bell (USA)

sorry for the link.
Could you help with that .zip? I cant seem to find it.
Thanks

Return to “MAME Discussion”