ZexFighter689
Posts: 1
Joined: Sat Jun 01, 2024 7:11 am

I'm not able to load anything in MAME since SSD migration! HELP!

Ever since I installed another M.2 SSD into my laptop (yes, my laptop has two M.2 SSD slots) and migrated all my emulation stuff, everything works fine albeit some adjustments except MAME. And when I try to boot up a game on MAME, instead of taking me to the specs screen or whatever you call it before the game starts, I get the message telling me "Required ROM/disk images for the selected system are missing or incorrect. Please acquire the correct files or select a different system." I have the game and the required files (in my case, I was gonna play Mushihimesama Futari but that f***ing message crushed my hopes of playing it on that weekend), WHY IS IT NOT BOOTING?! BOOT UP YOU PIECE OF TRASH! Sorry sorry, lost my cool. Where was I? Oh yeah, any game I try to load, I get that f***ing message. It's been the bane of my existence because I know it worked before but since I migrated my emulation stuff to my new SSD, it started becoming a problem for me. I hope this was an oversight in development. I tried deleting MAME, downloaded previous versions, relocated MAME and the files, redirected ROM files between both SSDs, you name it to no avail. I tried asking the Reddit community for answers but they weren't much help either. So I'm turning to this site in hopes of getting a solution to the nightmare I've been having. If you know of any solutions, please, please tell me! I've been desperately searching for answers ever since this I got this problem. Are you having the same problem I have? I hope I'm not the only one having this problem...
User avatar
Tafoid
Posts: 356
Joined: Thu Nov 06, 2014 12:50 pm
Location: USA
Contact: Website

Re: I'm not able to load anything in MAME since SSD migration! HELP!

ZexFighter689 wrote: Mon Jun 10, 2024 6:30 am Ever since I installed another M.2 SSD into my laptop (yes, my laptop has two M.2 SSD slots) and migrated all my emulation stuff, everything works fine albeit some adjustments except MAME. And when I try to boot up a game on MAME, instead of taking me to the specs screen or whatever you call it before the game starts, I get the message telling me "Required ROM/disk images for the selected system are missing or incorrect. Please acquire the correct files or select a different system." I have the game and the required files (in my case, I was gonna play Mushihimesama Futari but that f***ing message crushed my hopes of playing it on that weekend), WHY IS IT NOT BOOTING?! BOOT UP YOU PIECE OF TRASH! Sorry sorry, lost my cool. Where was I? Oh yeah, any game I try to load, I get that f***ing message. It's been the bane of my existence because I know it worked before but since I migrated my emulation stuff to my new SSD, it started becoming a problem for me. I hope this was an oversight in development. I tried deleting MAME, downloaded previous versions, relocated MAME and the files, redirected ROM files between both SSDs, you name it to no avail. I tried asking the Reddit community for answers but they weren't much help either. So I'm turning to this site in hopes of getting a solution to the nightmare I've been having. If you know of any solutions, please, please tell me! I've been desperately searching for answers ever since this I got this problem. Are you having the same problem I have? I hope I'm not the only one having this problem...

My gut tells me you need to do some special rompath configuration with possible manual edits to your mame.ini to make sure all of your instances of places where romsets are supposed to be searched in are covered. Best way to see what is happening is run MAME from a command-line/prompt using the following assuming Windows: mame -verbose > capture.txt. The output as MAME attempts to load/run items will be output here. This text would be helpful in determining what might be happening when you attempt/fail a machine start.

It would also be nice to know your configuration/machine (CPU/OS/Storage) or any other info that might not be standard.

Return to “MAME Discussion”