User avatar
mandragora
Posts: 9
Joined: Mon Jan 29, 2018 1:38 am

How to compile older mame version (0.152)?

Mon Feb 04, 2019 8:05 pm

Dear Mame Team,

I'm having trouble finding mingw-mame-w32 build tools for 0.152 source.
Could you please help me locate this package? Google search only poins to dangerous
scripted site in china.
This was last version that did not crash under Windows XP sp3 with nv4_disp.dll error.
ATI stopped working after sp2, when MicroYouKnowWho buggered Catalyst drivers.
That doesn't leave many other video options. Software rendering is slow and jerky.
I would be very grateful for your kind help.
Thank you.

- Aleksandr
mailto%3Aaleksandrbmelnikov%40gmail%2Ecom

User avatar
Robert
Posts: 67
Joined: Thu Nov 06, 2014 12:44 pm
Location: Land of Oz
Contact: Website

Re: How to compile older mame version (0.152)?

Wed Feb 06, 2019 1:51 pm

You can get old windows versions at https://www.mamedev.org/oldrel.html , there's no need to compile.

User avatar
Tafoid
Posts: 133
Joined: Thu Nov 06, 2014 12:50 pm
Location: Vermont USA
Contact: Website

Re: How to compile older mame version (0.152)?

Wed Feb 06, 2019 7:54 pm

Robert wrote:
Wed Feb 06, 2019 1:51 pm
You can get old windows versions at https://www.mamedev.org/oldrel.html , there's no need to compile.

Robert was correct in pointing you to this OFFICIAL download archive for binaries and sources. MAMEDEV encourages only using later/current versions and/or compile tools. I'm assuming you tried to compile the older source with current (or more recent tools)? We do not carry any tools on MAMEDEV currently beyond the last few packages and they are located, or in a "Previous version" link at the bottom, here: https://www.mamedev.org/tools/

That said, there is a post here at MAMEWORLD which someone compiled a list of older tools and packages but hasn't been updated in quite a while. This may have something you can use. Setting up and using such packages, however, you are on your own: http://www.mameworld.info/ubbthreads/sh ... ber=207730

Beyond that there isn't much we can do to help with your issues. While OS's like Windows XP are still used by some, such support would likely disappear once MAME makes a move to support only 64-bit applications. Microsoft itself first started withdrawing support for XP nearly 10 years ago, not long after it's final Service Pack.

Regarding your original issue, I'm rather sure you have a graphics driver issue (new driver, older card). I seem remember about that time Nvidia/GeForce video cards had windows driver trouble which would cause MAME in some cases of later drivers at the time cause a system crash or "BSOD". You may want to rollback your graphics driver which worked for many at the time. Get some ideas googling "nv4_disp.dll mame".

User avatar
mandragora
Posts: 9
Joined: Mon Jan 29, 2018 1:38 am

Re: How to compile older mame version (0.152)?

Thu Feb 07, 2019 12:18 am

Dear Tafoid, <--- Error correction

Thank you for requested link.
Most of arcade stuff ran on Zilog Z-81A CPU.
Funny, how bad they run on i7 in Wn64.
Yet, everything is fine on AM2 in Win32.
Let's blame it on MS! I think my next one
will be Penguin Powered.

Ladies and gentlemen,
http://www.mameworld.info/ubbthreads/sh ... ber=207730
Earmark that page, and download while you can.
It may very well be last place to find outdated build tools.
Not that you couldn't pull gcc, c++, and qt binaries on your own,
but creating same structured environment, without shopping list,
is sure to fail.
Good luck, folks.
- Aleksandr
Edit: [SOLVED] 100% Working.

Return to “MAME Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests