FrankieO
Posts: 2
Joined: Sun Apr 28, 2019 4:35 pm

Re: Windows Vista compatibility lost with Mame 0.209 ?

Mon May 20, 2019 8:51 pm

Hi Folks,

as the orignal poster of the problem I would like to thank you for all your suggestions.
Unfortunately neither 0.208 nor 0.209 binaries (both 32 and 64 bit) work.
So I downloaded the source and compiled myself (64-bit).
Even when compiled on my Vista Machine the result still shows the error.
As stated in my original post the problem is caused by a group of functions that MS moved from psapi to kernel32 from Windows 7 onwards.

This is reflected in mingw64/x86_64-w64-mingw32/include/psapi.h .

For Vista and XP a

#define PSAPI_VERSION 1

would be needed.
On my Vista machine the automatic selection in this file does not work.
So I put the define right in front of the selection mechanism, cleaned up and recompiled.
Now it works.
The clean way is most probably to define the PSAPI_VERSION in the makefile (did not try this as compilation on my machine takes several hours).

PS.: What is the rationale behind the MODERN_WIN_API switch in the makefile ???

Return to “MAME Discussion”

Who is online

Users browsing this forum: No registered users and 6 guests