Hyperspinner5000
Posts:2
Joined:Fri Dec 27, 2019 7:16 pm
Unusual behaviour with Logitech G27

Sat Jan 04, 2020 3:14 pm

Hi, i am currently experiencing a few issues using a logitech g27 on certain games that MAME emulates. I will start with 'Hard Drivin'. I understand there is a certain technique to making sure the gears work properly and i have followed this to a 'T' (there is a very good youtube video on how to map each what gear to which analogue X and Y inc and dec). However when in game i notice it sometimes wants to bounce into second gear for no reason when it is in neutral. Almost like its default is second instead of neutral. This can sometimes but not always be rectified by putting it in fourth gear and waiting for a bit, but it is so very random i am not sure what i am doing wrong. I have tested the hardware and all seems to be in full working order as expected.

My second issue with this game in particular is when i start it is like the brake is stuck permanantly on. This means you crawl too slow in first and then when switching to second the car stalls out. Now there a re a good few options that MAME offers in regards to fine tuning your setup and in particular the brakes. Reversing the brakes does not seem to make a difference. If this were the case then stamping on the brakes while driving would cure the problem as the opposite effect would be in action. I have also tried many sensitity settings to see what is wrong but just cant seem to make this work properly as it should. Also sometimes reversing the brakes or not reversing them has the added bonus of all of a sudden making the clutch rev the car when pressed while at the same time acting as the clutch. So it sort of swaps the accellerator for the clutch but only when pressed and the accellerator still works as intended. It is most confusing.

In non MAME related games (project cars, euro truck sim etc etc) and the windows controller tool everything works exactly as it should so i am convinced it is not a hardware or even windows software setup like the logitech profiler. So if this is a MAME issue, what am i doing wrong and how can i set this up correctly?
Does anyone who owns a G27 specifically want to post me their input AND analogue settings for there MAME racer so i may copy it and report back?

I can provide more information on request. Kind thanks.

User avatar
Tafoid
Posts:157
Joined:Thu Nov 06, 2014 12:50 pm
Location:USA
Contact: Website

Re: Unusual behaviour with Logitech G27

Sat Jan 04, 2020 4:13 pm

Hyperspinner5000 wrote:
Sat Jan 04, 2020 3:14 pm
Hi, i am currently experiencing a few issues using a logitech g27 on certain games that MAME emulates. I will start with 'Hard Drivin'. I understand there is a certain technique to making sure the gears work properly and i have followed this to a 'T' (there is a very good youtube video on how to map each what gear to which analogue X and Y inc and dec). However when in game i notice it sometimes wants to bounce into second gear for no reason when it is in neutral. Almost like its default is second instead of neutral. This can sometimes but not always be rectified by putting it in fourth gear and waiting for a bit, but it is so very random i am not sure what i am doing wrong. I have tested the hardware and all seems to be in full working order as expected.

My second issue with this game in particular is when i start it is like the brake is stuck permanantly on. This means you crawl too slow in first and then when switching to second the car stalls out. Now there a re a good few options that MAME offers in regards to fine tuning your setup and in particular the brakes. Reversing the brakes does not seem to make a difference. If this were the case then stamping on the brakes while driving would cure the problem as the opposite effect would be in action. I have also tried many sensitity settings to see what is wrong but just cant seem to make this work properly as it should. Also sometimes reversing the brakes or not reversing them has the added bonus of all of a sudden making the clutch rev the car when pressed while at the same time acting as the clutch. So it sort of swaps the accellerator for the clutch but only when pressed and the accellerator still works as intended. It is most confusing.

In non MAME related games (project cars, euro truck sim etc etc) and the windows controller tool everything works exactly as it should so i am convinced it is not a hardware or even windows software setup like the logitech profiler. So if this is a MAME issue, what am i doing wrong and how can i set this up correctly?
Does anyone who owns a G27 specifically want to post me their input AND analogue settings for there MAME racer so i may copy it and report back?

I can provide more information on request. Kind thanks.

I've been suggesting people watch/view this video for examples on how to map their driving controllers for use with MAME. Hopefully it helps.
https://www.youtube.com/watch?v=5_mEe0tf6GU

Hyperspinner5000
Posts:2
Joined:Fri Dec 27, 2019 7:16 pm

Re: Unusual behaviour with Logitech G27

Sat Jan 04, 2020 4:43 pm

Thanks for the reply. I have watched that video not too long ago and found it quite useful for understanding some of the general setup options in MAME. I think what i am having trouble with is the random non-logical issues that dont make sense. For example if the steering wheel darts about too much and the sensitivity is high, tuning that to a lower number till you get the feel you want is quite logical and easy to setup. Its the non-logical i cant get my head round. Such as the clutch acting as the accellerator when the brake is reversed and neither brake reverse on or off or any of the sensitity and digital speed options seem to affect the appearance of the brakes being permanantly pressed down. I was wondering if anyone has a layout i can copy (at least starting with 'Hard Drivin') so i can see where i have gone wrong and make some sense of it.

Once again though, thank you.

Return to “MAME Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest